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The University of Melbourne Infoblox

Introduction

The University of Melbourne has adopted the Infoblox IPAM to manage the University’s DNS and
DHCP system. The Infoblox system is managed primarily through a web browser and a Java
application that is downloaded automatically when launching the web application.

Audience

IS staff and Faculty/Department Administrators who need to manage host/subnets/DHCPs in the
IPAM systems.

Purpose

This document intends to assist and provide initial instructions to users managing entries in the
IPAM system.

Definitions

DNS — Domain Name Services

DHCP — Dynamic Host Control Protocol

IPAM — IP Address Management

Grid — Collection of Infoblox appliances managed from a central point

GUI - Graphical User Interface, called the Grid Manager in this environment.

System Overview

The system consists of six appliances connected together using the Infoblox grid technology.
They are all managed from a central point, the Grid Master. All system functions as well as DNS
and DHCP are accessed using the GUI, called the Grid Manager. Some of the appliances will
serve DNS and some DHCP. This is transparent to the user as it is configured by the system
administrator at the time of the installation.
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Accessing the IPAM system

First Time Users

To access the Grid Manager on workstations running Microsoft Windows or Linux you must have
a supported version of Java installed. Details of supported versions of Java can be viewed in the
Release Notes for the version of Infoblox software being run on the workstation.

When the initial connection is made via the web browser (https://I[PAM.unimelb.edu.au), a Java
application will download to your workstation. You are prompted, during this process, for
permission to install a shortcut on your desktop. Granting permission for the shortcut will make
future connections to the Grid Manager quicker and easier.

I / .Gn'd Manager - Windows Internet Explorer

1<res- |3§3 https: ffipam.unimelb, edu, auj Vl & _‘? X |A"noﬁlf ‘ 2~
File Edit %ew Favorites Tools  Help
w @ I%]q@mpanded Accounts at TAD... | 5 Grid Manager x I_I - B - @ - [Shrage - @Toos »
.
Grid Manager

Restricted Access - Login Required

Welcome to the Unimelb IPAM system. To L]
use this system requires Java installed
on a Windows or Linux PC.

y Java~ starting...

|~

| &
€ Internet H100% v

Note: the shortcut and Java application are version specific and must be re-created when a new
version of the Infoblox software is installed on the workstation.
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Accessing IPAM

The Grid Manager is accessible via the desktop shortcut or via a web browser
(https://IPAM.unimelb.edu.au). The website authenticates using the University’s Active Directory.
After entering your AD username and password, you will be able to access pre-defined zones
and subnets.

e

% NIOS GUI: 4.2r4-1-sp1-35692 M=
Options

Restricted Access: Login Required

Welcome to the Unimelb IPAM svstem, To use this syskem requires Java
installed on a Windows ar Linuw PPC,

Please login using wour central University username and password,

Hostname: | arm, unimelb, edu. au v|

sername: | | |

Password: | |

Login H Zancel ]
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Navigating the IPAM system

The Grid Manager has several contexts (also known as Grids) that are available. These can be
seen in the screenshot below (outlined in red) and are: Grid; DNS; DHCP and IPAM; File
Distribution; Administrators; and Global Search.

The University encourages the use of DHCP and IPAM ; DNS; and Global Search grids only.

=+ Grid Manager: chd@ipam. unimelb.edu.au

File Edit Tools Yiew ‘Window Help

H&S &

s and [[Eons |s3DHP and PAM £ AAA (= File Distribution g Administrators Q) Global Search ‘
B Infablo: e DNS Members Q. = OO records 52

Mame Type Comrment

= @ Infoblox Yiews Filker |F'.II records v| Goto |
= E inkernal

Mame Type Value

& B Forward-Mapping Zones _—
IPv4 Reverse-Mapping Zones
IPvE Reverse-Mapping Zones
@ external
@ Shared Record Groups
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Infoblox

Global Search

IPAM has a global search feature which enables you to search through the whole IPAM

database.

To perform a search

1. Select the Global Search grid and enter the string for which you wish to search.

2. Click on the Search button.

The search will return all matching hosts, aliases (or Cname), subnets, zones, etc.

File Edit Tools Wiew Window Help

= crid DNS 7 DHCP and PAM £ AAA (=4 File Distribution g Administrators | €, Glabal Search

=0

Searches are case insensitive
Marne Type Matched Property Matched Yalue A
E 128,250.243.194 Fixed Address IP Address 128,250.245.194
|as(128,250,243,195 Fixed Address IP Address 128,250.245.195
|as(128,250,243.193 Fixed Address IP Address 128,250.245.193
|a(128,250,213.2 Fixed Address 1P Address 128,250.213.2
|a%(128,250,213.3 Fixed Address 1P Address 125,250.213.3
|a%(128,250,213.1 Fixed Address IP Address 125,250.213.1
|a%/128,250,223.2 Fixed Address IP Address 125,250.223.2
|a%/128,250,223.3 Fixed Address IP Address 125,250.223.3
|o%128.250,223.1 Fixed Address IP Address 125,250.223.1
|o%128.250,233.2 Fixed Address IP address 125,250.233.2
|o%[128.250.233.3 Fixed Address 1P Address 125.250.233.3
|a%(125.250,233.1 Fixed Address 1P Address 125.250.233.1
E 125.250.233.130 Fixed Address 1P Address 125.250.233.130
E 128.250.233.131 Fixed Address IP Address 128.250.233.131
E 128,250.253.129 Fixed Address IP Address 128.,250.235.129
E 128,250,243.66 Fixed Address IP Address 128,250.2435.66
E 128,250,243.67 Fixed Address IP Address 128,250.2435.67
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Add an Internal Host

Internal hosts should be added via the DHCP and IPAM grid.

Before adding a host you should enable IP Address Management from the View menu. This
view allows you to see both used and unused IP addresses within a subnet.

To add a new host

1. Select the subnet on the LHS then click on the IP Address Management view.

2. Right click on an unused IP address and select Add resource records > Host  from the
context menu.
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The Host Record Properties form will display.

3. Enter a name for the host then click on the Select zone button.
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4. Select and expand the internal then Forward-Mapping Zones .

5. Select the required zone then click the OK button.
You can now see the zone attribute displayed next to the host name.

6. Add the IP address , MAC address (needs to be in the format 00:00:00:00:00:00) and
Aliases (also know as Cname records) if required for this host.

7. Once you enter all the required information for this host, save your changes.
To save:
select File > Save from the menu or

click on the X on the top right corner of the Add host tab, the system will prompt you to
save before closing the tab.
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Add an External Host

External hosts refer to IP addresses outside the Unimelb network ranges (i.e.: not 128.250.X.X
or 172.X.X.X). These are usually web addresses hosted externally and cannot be located via
browsing networks in the DHCP and IPAM grid. As such they need to be added via the DNS
grid.

To add a new host

1. Select the zone from the LHS then right click to select Add resource records > Host  from
the context menu.
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The Host Record Properties form will display (the zone information should be populated).

2. Enter a name for the host and add the IP address , MAC address (needs to be in the format
00:00:00:00:00:00) and Aliases (also know as Cname records) if required for this host.

3. Once you enter all the required information for this host, save your changes.
To save:
select File > Save from the menu or

click on the X on the top right corner of the Add host tab, the system will prompt you to
save before closing the tab.
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Modify Existing Hosts

You can view/modify existing host by double clicking on its subnet, then you can view it in the IP
Address Management tab or via the Global Search grid.

If you are locating a host by browsing through the list of networks under the DHCP and IPAM
view, you will see each Host has two views attached to it (Internal and External).

Internal view is the view within the university network
External view is the view that displays to those outside the university network

You should only modify the Internal view — any changes you make will be replicated to the
External view periodically.

To modify a host
1. Locate the Internal view of the host.

2. Make the required changes to the host name and IP address , MAC address (needs to be in
the format 00:00:00:00:00:00) or Aliases (also know as Cname records) for the selected
host.

3. Once you have updated all the required information for this host, save your changes.
To save:
select File > Save from the menu or

click on the X on the top right corner of the Edit host tab, the system will prompt you to
save before closing the tab.
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Manage MAC address filters
Modifying MAC address filters may be done via the DHCP and IPAM grid.

Please note MAC address filters can only be added by IS. To request a new MAC address filters,
please send an email to it-help@unimelb.edu.auf your department has multiple IPAM groups,

please specify what groups should have access to the MAC address filter, eg 500GG-MDHS-
Dentistry.

To add MAC addresses to existing MAC address filter s

1. Right click on the appropriate MAC address filter, and select the “Add MAC address...".

2. Then input the MAC address in the format of “00:00:00:00:00:00” and add any user
information if relevant.
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3. Once you have updated all the required information for this MAC address, save changes by,
select File > Save from the menu or

click on the X on the top right corner of the Add Mac Address tab, the system will
prompt you to save before closing the tab.
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To modify existing MAC address filter settings

4. Double click on the appropriate MAC address filter and edit any required fields.

5. Once you have updated all the required information for this filter, you need to save your
changes.

To save:
select File > Save from the menu or

click on the X on the top right corner of the Edit Filter tab, IPAM will prompt you to save
before closing the tab.
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Add/modify DHCP Pool

Adding a DHCP pool may be done via the DHCP and IPAM grid.
To add a DHCP pool

1. Select the subnet from LHS then right click to select Add DHCP Range Using Template
from the context menu.

A Create Range Using Template window will display.
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2. Click on the Select Range Template button and select the Standard-dhcp-range template.

Click OK when done to close this window and open the Add DHCP Range window.
Enter the Start Address and End Address of the DHCP range.

Expand the Member Assignment section and make sure the Enable DHCP failover
checkbox is ticked.

6. Click on the Select Association button and select DHCP-failover from the list then close the
window.
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7. If a MAC Address Filter is to be applied, Click on the ‘Add’ button next to the ‘MAC Address
Filter Rule ’, in the ‘Filter Rules ’ section.

Then the ‘MAC Address Filter Rule ' window will pop up, and you can select the MAC filters
that you have been given access to, and decide whether to deny or allow MAC addresses
registered in the filter.

Note: Departments needs to first contact IS to request a MAC filter to be created before they
can manage MAC Address filters.

8. Save you changes and exit the Add DHCP Range window.
The DHCP range is now created (as displayed in screen shot below).
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To view/modify existing DHCP ranges
9. Double click on the appropriate DHCP subnet.
10. Select the Ranges, Fixed Addresses and Filters  tab.
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Add/modify Subnets
Adding a new subnet may be done via the DHCP and IPAM grid.

To add a subnet

1. Select Networks from the LHS then right click to select Add Network Using Template from
the context menu.

The Create Network and Children Using Template  dialog window will display.
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2. Click on the Select Network Template button and then select the Standard template.

3. Click OK when done to close the Select Network Template window.

4. Enter the Network Address (e.g. 128.250.2.100) and select the Netmask (e.g./24) of the
network.

5. Click OK when done.

In the Member Assignment section of the Network Properties tab, you should see
dhcpl.unimelb.edu.au and dhcp2.unimelb.edu.au registered as DHCP members.
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Add/modify Zones

Zones were previous known as domains in IPREG.

Adding or modifying zones should be done via the DNS grid. IPAM presents two views in the
DNS grid, internal and external. We will only use the internal view.

To add a zone

1. Expand Infoblox Views > internal on the LHS to display Forward Mapping Zones .

2. Select Forward-Mapping Zone from the LHS and right click to select Add Forward-Mapping
Zone > Authoritative  from the context menu.
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The Add Forward Authoritative Zone  tab will display.

3. Enter the required attributes and make sure the NS Group value is Central.

4. Once you have entered all the required information for this zone, save your changes.
To save:

select File > Save from the menu or

click on the X on the top right corner of the Add Forward Authoritative Zone tab, the
system will prompt you to save before closing the tab.

To view/modify existing zones double click on the LHS zone browser in the DNS grid or use the
Global Search grid.
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Known Issues

There is a known compatibility issue between IPAM and the Java version on Mac OS. It is
recommended to have IPAM run under windows platform.
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